Item Status Report doesn't match items needing re-order

Stock Items / Build Orders / BoMs / Item Prices / Physical Counts

Re: Item Status Report doesn't match items needing re-order

by Rodders » Fri Jan 29, 2010 7:56 am

Supplementary

OK, I played with the SQL database and guess what, when I looked at the inventory location table there's no entries for record IDs 0 or 1. So I created two new locations in SQL, gave them IDs 0 and 1 and named them TEST 00 and TEST 01. Look what happened to the 'edit orders' list.....



As if by magic, the blank entries in the location column have changed to TEST 00!

So, I guess auto-generated orders default to location 0.

Not only that, but all my 'missing' stock (the original object of this thread) now appears in the stock report in location TEST 00 as well....



Problem is, if I renumber my primary location in the database to 0 (it's currently 2) the stock figures won't follow it because they're pointed at location record 2, not record 0. Does this mean I will have to edit every inventory entry in the database to move the stock figures to the re-numbered location?
Rodders  

Re: Item Status Report doesn't match items needing re-order

by admin » Fri Jan 29, 2010 11:46 pm

First off, please make sure you have a default inventory location set in Inventory->Setup Inventory->Standard GL Accounts. You probably already have this set but I didn't have access to this section and want to verify before proceeding. If this is set then the problem is likely with the following:

When you back up and restore a database it should be the same version of NolaPro. Since you installed a new version of NolaPro and imported your database from the older version not everything has been updated. I recommend backing up your live install and updating that version.

If you would still like to try this first on your test install, run the update for that again and see if it works. Again, the location is filling in on my tests.
admin Site Admin  

Re: Item Status Report doesn't match items needing re-order

by Rodders » Mon Feb 01, 2010 4:05 am

Sorry, I should have said that the database I edited was the correct one for the 'old' version of NP so all my last post applies to my original installation and original database, i.e. the database is the correct one for the version I use. The default location entry was blank. As soon as I edited it so it had data in all the missing stock started appearing in the stock report and the order summary had a location for auto-generated orders.

However, to prove or disprove the point I will create a copy of my current version of NP then upgrade it using your upgrade package. That should update the database to meet the current spec. Then I'll take another look at the SQL and see what happens....

I can confirm that the default location is set to 'TMH' in our live version.

Now you have closed this forum how do I contact you?
Rodders  

Re: Item Status Report doesn't match items needing re-order

by Rodders » Wed Feb 03, 2010 2:25 pm

Wow - it's colder there than it is here!

OK - I've made a copy of my live system, then I ran the upgrade to the latest NP version. The problem is still there, exactly as before. I won't play with the SQL 'til you've confirmed you've looked and agree. URL is our usual plus 'nolatest' instead of the live one. Username and password unchanged (obviously, as it's an upgrade....). I'll give you full access as it's only a test installation.

Would still like to know what happens now this forum is closed down and also which version(s) of osCommerce I can use with oscom Tell me and I'll buy the upgrade from you.

BR

Rod
Rodders  

Re: Item Status Report doesn't match items needing re-order

by admin » Tue Feb 09, 2010 10:40 am

Please submit all inquiries to http://support.nolapro.com
admin Site Admin  

Previous

Return to Inventory